Installing opencv-python as a pip dependency requires using pip 8.1.0 (which added binary wheel support on Linux) or later.

To update pip  on Code Ocean, simply add it as a pip  dependency (this is the equivalent of running the command pip install -U pip) – you should get a message telling you it's already installed. Then click the version number to edit it, and select latest.

Did this answer your question?